SSL Insecure Content Fixer

Описание

Премахва предупрежденията за несигурно или смесено съдържание при зареждането на вашия WordPress сайт през HTTPS. С инсталирането на разширението SSL Insecure Content Fixer ще разрешите голяма част от тези проблеми без никакви усилия. Оставащите грешки могат да бъдат диагностицирани с няколко прости инструмента.

Когато инсталирате SSL Insecure Content Fixer, се активират настройките по подразбиране и разширението ще започне автоматично да извършва някои базови поправки по вашия сайт, които отговарят на стандартното ниво. Можете да изберете по-разширен набор от поправки, ако вашият сайт се нуждае от тях.

WordPress Multisite има допълнителна страница с настройки на мрежата. Тя може да се използва за задаването на настройки по подразбиране за всички сайтове в мрежата, така че техните администратори да променят индивидуални настройки само там, където е необходима промяна.

Вижте сайта на разширението SSL Insecure Content Fixer за повече подробности.

Преводи

Много благодарности за щедрите усилия на нашите преводачи:

Ако искате да помогнете с превода на това разширение, регистрирайте профил и се захващайте.

Политика на поверителност

SSL Insecure Content Fixer не събира персонална информация и не използва бисквитки.

Инсталиране

  1. Използвайте процедурата за автоматично инсталиране през админ панела на WordPress или изтеглете .zip файла, разархивирайте го и качете получената папка в директорията /wp-content/plugins/. Прочетете статията Инсталиране на разширения в базата знания на WordPress за подробности.
  2. Активирайте разширението от меню „Разширения“ на WordPress.

Ако вашият браузер продължава да докладва несигурно или смесено съдържание (insecure/mixed content), прочетете статията Почистване на съдържание.

ЧЗВ

Как да разбера каква е причината за предупреждението за несигурно / смесено съдържание?

Проверете в конзолата на браузера.

ВАЖНО: след като отворите конзолата, презаредете страницата, за да може браузерът да опита повторно да зареди несигурното съдържание и да покаже съобщенията за грешка.

Why No Padlock? предлага наистина добър тестов инструмент за диагностициране на проблеми с HTTPS.

Получавам предупреждения за „несигурно съдържание“ (insecure content) за части от моето съдържание

Най-вероятно зареждате съдържание (например изображение) от URL адрес, започващ с „http:“. Махнете тази част от адреса, но запазете наклонените черти, ето така: //www.example.com/image.png; по този начин браузерът ви ще зарежда съдържанието чрез HTTPS винаги, когато страницата го изисква. Дори още по-добре е да заместите „http:“ със „https:“, така че изображенията винаги да се зареждат чрез HTTPS: https://www.example.com/image.png.

Ако страницата може да се зарежда извън уеб браузер (например в email или други електронни документи), трябва винаги да посочвате протокол на връзката и е най-добре той да бъде „https:“ (допускаме, че имате SSL сертификат). Прочетете Изчистване на съдържание за повече подробности.

Моят сайт се намира зад балансер или обратно прокси

Ако вашият сайт е разположен зад балансер или друг вид обратно прокси и WordPress не може да определи кога се използва HTTPS, трябва да изберете подходящата настройка за разпознаване на HTTPS. Прочетете моята публикация WordPress is_ssl() doesn’t work behind some load balancers за повече подробности.

Получавам предупреждения за важни за работата на WordPress скриптове като jquery.js

Вероятно се намирате зад обратно прокси (reverse proxy) — вижте ЧЗВ по-горе в частта за балансерите и обратните проксита, и изпълнете SSL теста от менюто „Инструменти“ в админ панела на WordPress.

Промених настройките за откриване на HTTPS и сега не мога да вляза в админ панела

Вероятно се получава конфликт с друго разширение, което също се опитва да поправи работата на HTTPS. Добавете следния ред във вашия wp-config.php файл над редовете в частта ABSPATH. След това можете да възстановите настройките по подразбиране на разширението, преди да продължите.

define('SSLFIX_PLUGIN_NO_HTTPS_DETECT', true);
Все още получавам предупреждения за несигурно съдържание (insecure content) в моите страници, зареждани през HTTPS

Пишете за това във форума за поддръжка и не забравяйте да сложите връзка към страницата. Публикации без работещи връзки най-вероятно ще бъдат игнорирани.

Моето разширение за WordPress присъства в списъка с проблемни разширения, но аз вече съм поправил проблема

Отлично! Кажете ми кое разширение е вашето и как мога да проверявам за нови версии, и аз ще премахна „поправката“ при публикуването на следващата версия.

Отзиви

юли 13, 2019
Great plugin, with lots of option. Certainly recommended. Fixed my js file loading via http, which I couldn't fix in code due to old plugin. please keep it up to date.
април 27, 2019
Users like me who were issued for example, with the potential problem that secured padlock doesn't appear on the front but does at the backend, etc, can now be solved with this plugin easily. Plugin scanned all the possible issues and errors and helped me to solve the problem that I would not figure out by myself in no time. Thanks for the plugin author!
Прочетете всички 191 отзива

Сътрудници и разработчици

“SSL Insecure Content Fixer” е софтуер с отворен код. Към разширението са допринесли следните хора.

Сътрудници

“SSL Insecure Content Fixer” е преведено на 14 езика. Благодарности на преводачите за техния принос.

Превеждане на “SSL Insecure Content Fixer” на вашия език.

Имате интерес към разработване?

Преглеждане на кода, разглеждане на SVN хранилище, или абонамент към програмната история (log) чрез RSS.

Списък с промени

Пълният списък с промени се намира в GitHub. Най-новото:

2.7.2

Released 2018-12-04

  • fixed: some hard-coded link elements (e.g. stylesheets) when href is the first attribute