Помощ » Проблеми » Проблем със CSS

  • Затворена ekshan59

    (@ekshan59)


    ekshan59
    Регистриран
    Публикувано преди 1 day #

    Здравейте!
    Инсталирах WordPress на линукс ОС и Апаче.
    Когато активирам някоя тема, не се показва коректно.
    Влизам от друга машина и всичко стои в колона, ляво на брузъра,
    като HTML
    Какво да проверя ?
    Не съм програмист??
    Благодаря !

    Stanko Metodiev
    Модератор
    Публикувано преди 20 hours #

    Като за начало можеш да пуснеш отделна тема за твоят проблем, защото е различен от горният. Ако може да добавиш и малко повече информация какво точно ти изписа, накоя друга снимка също би била полезна.

    alordiel
    Регистриран
    Публикувано преди 20 hours #

    Освен Апачи инсталирахте ли MySQL и PHP? До колкото разбирам не ви се зарежда css и нещата ви излизат като plain html.Проблема в случая може да е в това, че темата не намира css-си. Ако отваряте сайта си под google chrome може с десен бутон да кликнете и да изберете inspect element. Ще ви се отвори Developers tools, презаредете страницата и отидете на таба Console, там ще ви бъдат изплюти разни грешки ако има такива и от тях може да се ориентирате какво не е наред.

    Отговор
    Инсталирал съм Msql и PHP.
    Но с кода няма да се оправя ??
    Мога да редактирам файла, но трябва да знам точно кой и с какво да заменя. Аматьорска работа, какво да се прави.
    Оставям линк и отворен порт..http://93.155.179.46/

Виждате 15 отговора - 1 от 15 (от 42 общо)
  • Това, което виждам като грешка е че имаш около 40 грешки и всичките са 404 – страницата не е намерена и става въпрос за всички разширения и css и js файлове. Виждам и че си ги инсталирал директно в (предполагам) www/var папката, което не е хубаво. Създайси в тази папка друга и там инсталирай. Най вероятно имаш проблем с правомощията на файловете и не са достъпни. Пробвай с нова инсталация и ако не стане ще бориме проблема с правата.
    И ето едно много простичко упътване как да го инсталирате на линукс.

    Вече съм пробвал с преинсталация 2 пъти?? Не ства.
    Сега открих, че на единия баузър на локалната машина всичко е точно.
    На „Epiphany“ – стана!
    На „Dilio“ , „NetSurf“ и всички останали НЕ става.
    За темите, наистина добавях. Но тази която е избрана, доѝде с инсталацията.
    Ако добавя нова папка за теми, не е ли проблем, че вече има такава?
    Сега темите излизат коректно, когато вляза от таблото за управление и мога да сменям, Както инсталираните така и тези които добавих. Мога да сменя Име, Цвят да добавя меню – за др. не знам как. Но ако е нещо с правата по какво да разбера?
    Нямам теми Премиум..
    Ако някои има браузър „Epiphany“ нека погледне!
    Благодаря!

    Забравих да кажа, че последно оставих Българската версия, ако това има значение..

    Разгледах папките CSS и JS но мога да кажа само това, че там има около 60 файла.
    Очаквам инстукции??
    Не се отказвам лесно.

    Тъй – малко в страни – нещата ги гледай на FireFox или Chromium/Chrome, това са най ползваните браузари и другите са с толкова нисък проблем на ползване, че е безсмислено да гледаш тях (това всичкото – защото различни браузари показват нещата по различен начин и различни html елементи и css стилове се чупят при различните браузари).

    Ta сега едно по едно. Кажи къде си разархивирал WordPress ( трябва ми пълният път до WordPress папката).

    Второ – имам опасения, че става въпрос за права на самата папка, та можеш ли да работиш с терминала на линукс?

    И това че не се отказваш лесно е много хубаво : ) ще ти трябва търпение, че бавно реагираме понякога ; )

    Аз не бързам когато стане.
    С терминала смятам да се оправя. Все пак сам инсталирах всичко до тук.
    Wordpress e в /HOME/VAR/WWW.
    Като отворя /WWW/, виждам дирекно папките – WP-admin, wp-content wp-includes и други свободни файлове.

    Apache2, MySql и PHP5 са в /etc/.

    Тъй, вие ли си преместихте var/www в home? Или това си по подразбиране от LAMP-а? защото обикновенно нещата си седят в var/www.
    Ако вие сте го преместили – ще трябва да се направят едни допълнителни настройки, които може да видите ей тук.
    Иначе можете в терминала да пробвате :
    sudo chown -R www-data:www-data /home/var/www
    Което ще смени правата на папката (и всички подпапки на тази директория) на групата www-data. След като цъкете ентер ще ви иска парола.
    И да видим тогава какво ще е положението. Пък иначе ще го мислим евентуално за нова инсталация стъпка по стъпка, но първо по важно ми да разбера дали сте местили папката var/www…

    Явно аз не се изразявам както трябва. Не съм местил или пренасочвал нищо.
    Просто като вляза във файлове най отгоре пише HOME, и после са наредени всички директории, като /VAR/ е последна в колоната.Предните неша инсталирах по инстукции от тук http://www.rpi.bg/2014/инсталация-на-apache-mysql-и-php-под-raspbian/#more-211 ,и всичко излезе както пише.
    А wordpress изтеглих тук от този саит в „tar.gz“.А инстукции за инсталация от форумите. Не беше лесно?? Като файла разархивирах в /WWW/.
    Той зипа си стои в данлоад не съм го трил.
    Сега влизам в WordPress с Парола.
    В MySql също, но освен при инсталацията повече не съм влизал.

    To сега влизам от работата си и виждам страницата си. Значи не е от Апачито или рутера, там съм се справил.
    По скоро как да проверя за тези права на папка. Това за самия WordPress ли става дума. Напиши няколко команди и какво трябва да излезе. Довечера да проверя.

    Сещам се че при инсталацията преименувах 1-на фаил на index.php
    Ako се знае къде чете браузъра CSS, да погледна какво има, и какво трябва да има мога да проверя. Не знам дали формулирам правилно въпросите.
    За това не се смейте много??

    Дошли са ми 4 обновления. 1 за превод и 3 за разширения. Да ги задействам ли?

    С обновленията нямате проблем – обновявайте.
    Но я споделете като напишете в бразузара си http://localhost какво ви изкарва?
    По принцип гайда, който сте ползвали става за rasbery машинки, но като цяло нещата са така, както са написани.
    А къде е бил този файл index.php, който сте променили?

    Със локала няма проблем. Напълно редовен сайт..

    Проблема е за всички останали. Като се влезе от друга машина.
    Като на IP-тo което изпратих.
    Нещо немога да пратя снимка??

Виждате 15 отговора - 1 от 15 (от 42 общо)
  • Темата ‘Проблем със CSS’ е затворена за нови отговори.