Помощ » Проблеми » Странен проблем в class.php

  • Затворена alekseybg

    (@alekseybg)


    От 2-3 дни забелязах странно съобщение в блога си. И по-точно в отделните страници (пример – „За Мен“).

    Screen

    Пише ми
    Warning: Cannot use a scalar value as an array in E:\xampp\htdocs\blog\wp-includes\classes.php on line 826

    А на ред 826 е следното
    $args[0]['has_children'] = ! empty( $children_elements[$element->$id_field] );

    Не съм пипал нищо по кода… наскоро си направих ъпдейт до бета 3 на 2.7, но като че ли в началото го нямаше този проблем :/ След това видях, че се беше прецакал пътя до папката където се качват медийните файлове и единствено него промених…

Виждате 4 отговора - 1 от 4 (от 4 общо)
  • Има голяма вероятност грешката да идва от някой плъгин. Ако използваш такива, изключи ги всичките и после ги включвай един по един за да разбереш кой е.
    Все пак 2.7 има промени по нея, които може да не се разбират с плъгините писани за предишни версии.
    Може, да е някой бъг и в бетата (затова е бета все пак) използвай функцията за обновяване, за да ти сложи най-новата версия на бета 3, в момента са на билд 2.7-beta3-9948.
    Ако си късметлия, проблемът ще е от някоя приставка. Ако и ъпгрейд до последната версия на wp не помогне, ще трябва да се задълбаем в точната грешка и да разберем какво точно я предизвиква и какво правят споменатите функции 😉

    на втори поглед, мисля че нещо подобно ми се е случвало и имаше нещо общо с някой плъгин за уиджет. може да пробваш първо да махнеш всичко от страничните ленти и после да преминеш към плъгините. успех.

    Thread Starter alekseybg

    (@alekseybg)

    Благодаря ти за отговора. Това с плугините попринцип наистина си беше вариант да е проблема, но вече го бях пробвал и не се оправи. Опитах и с widjet-ите, въпреки, че ползвам ограничено количество такива. Всичко изключих и пак не се оправи. Но пък реших да опитам да му дръпна един ъпдейт… оказа се, че това е начина… Не можах да разбера откъде идва проблема, но вече е решен.
    И вече даже не са на версия beta3-9948 ами 2.7-almost-rc-10002 🙂 Преди да направя ъпдейта аз пък бях на 9836 или нещо такова (максимум 2 дни да не съм проверявал за ъпдейти..)

    Извод – Ъпдейтвайте на макс! 🙂

    Има нови билдове по няколко пъти на ден мисля, аз обнових преди малко и съм на rc1 вече 🙂

Виждате 4 отговора - 1 от 4 (от 4 общо)
  • Темата ‘Странен проблем в class.php’ е затворена за нови отговори.