Помощ » Проблеми » Постовете ми изчезнаха от Блог страницата, след активи

  • Затворена lpashov

    (@lpashov)


    Здравейте,

    На сайта си съм инсталирал WPML Pro пакета, който включва и WPML CMS Nav. Понеже не исках да модифицирам кода на темата си, за да използвам навигацията чрез WPML CMS Nav, реших да инсталирам в допълнение Breadcrumb NavXT.

    Забелязах, че след активирането на Breadcrumb NavXT, имаше някакво съобщение, че някакви индекси са стари и трябва да се обновят, но не запомних съощението, реших че е нормално.
    Веднага след активирането на плъгина Breadcrumb NavXT, забелязах, че постовете ми не се появяват в Блог страницата. http://leanify.com/blog/
    Предполагам, че нещо е било променено безвъзвратно в базата, понеже сега вече не мога да покажа постовете си.
    Пробвах различно неща, за да си оправя проблема – деактивирах WPML CMS Nav, нямаше ефект.
    Деактивирах Breadcrumb NavXT – нямаше ефект. После дори го деинсталирах – нямаше ефект.
    Реших да пренасоча (през Settings -> Reading -> Posts page) блога да е към някоя от другите страници – отново без ефект.

    Сайта ми е:
    http://leanify.com
    Ползвам последните версии:
    WordPress (4.3)
    WPML CMS Nav (1.4.11)
    Breadcrumb NavXT (5.2.2)

    Някой знае ли как да си върна постовете в блога, без да се налага да преинсталирам сайта?

    Благодаря,
    Любо

Виждате 5 отговора - 1 от 5 (от 5 общо)
  • Модератор Stanko Metodiev

    (@metodiew)

    Сигурен ли си че в темата нямаш blog template, които да зарежда всички постове? Ако имаш такава опция, направи си нова страница с име и URL „blog“ и избери блог темплейта. След това добави страницата в менюто и постовете би трябвало да се покажат.
    Ако нямаш таква опция, сподели с каква тема си и сподели евентуални грешки и/или проблеми, които са се появили за да можем да прегледаме и други варианти.

    Thread Starter lpashov

    (@lpashov)

    Благодаря за отговора, Станко!

    Темата ми е Esteem Pro.
    Няма blog template.
    Забелязах, че ако в Settings -> Reading, избера опцията „Your latest posts“ в настройката за „Front page displays“, тогава front page-а ми събира постовете, както преди това ми беше блога. Само че тази опция не ми върши работа. Искам да използвам опцията „A static page“, където да мога да контролирам Front page и Posts page.

    Грешки на екрана не се появиха. Само съобщението, че някакви индекси са стари и искаше да ги обнови. Това се случи след активирането на Breadcrumb NavXT плъгина, като преди това вече бях активирал WPML плъгините.

    Има ли някъде място, където мога да видя логове с проблема?
    Иначе, на екрана се появява само това, което всеки може да види:
    http://leanify.com/blog/

    Явно, ако хвърля някаква грешка, тя е вътрешна…

    Модератор Stanko Metodiev

    (@metodiew)

    Тъй като това е платена premium тема ще трябва да се обърнеш към авторите ѝ, в случай че имаш други въпроси свързани с темата. В този форум се разглеждат въпроси свързани с теми и плъгини налични в WordPress.org.
    Това което можеш да опиташ е да направиш блог страница, дори и празна и да я избере шт опция за Blog page от Reading Settings. Ако темата е написана правилно, би трябвало да можеш да използваш static за homepage и въпросната страница за blog page.

    Thread Starter lpashov

    (@lpashov)

    Благодаря за отговора, Станко!
    Проблема се появява и с темите, които си идват стандартно с WordPress и не е свързан конкретно с Esteem Pro темата.
    Това, което предлагаш – да направя друга (дори празна) страница и да я избера от опция за Blog page от Reading Settings, го пробвах преди да започна да пиша по форумите и да търся решение 😉

    Снощи обаче открих какво предизвиква проблема. Предишния път съм сгрешил, предполагайки че причината е в Breadcrumb NavXT.
    Та, снощи си направих чиста инсталация, без платената тема, само със стандартната, инсталирах WPML плъгините и нямаше проблем. След малко, обаче системата откри, че има по-нова версия на WPML пакета и го ъпдейтнах. След този ъпдейт проблема се появи.

    А проблема е, че WordPress не може да събере постовете и да ги покаже в страницата, която е „нарочена“ за блог в Reading Settings-ите.
    В този момент не бях качил Breadcrumb NavXT – имаше само WPML.

    След това изтрих WPML плъгините и проблема се оправи.

    Направих бъг репорт на WPML, а информацията я споменавам и тук, в случай, че някой друг получи подобен проблем след последния update на WPML пакета.

    Поздрави,
    Любо

    Модератор Stanko Metodiev

    (@metodiew)

    Радвам се че си открил проблема и си се оправил, браво! 🙂

    Споменах това за Reading settings, защото не винаги хората които имат проблем и питат тук познават добре WordPress и това е ок, за това предпочитам да им дам нещо, което да тестват преди да пишат пак, в повечето случаи помага 🙂

    Ще маркирам темата като решена.

Виждате 5 отговора - 1 от 5 (от 5 общо)
  • Темата ‘Постовете ми изчезнаха от Блог страницата, след активи’ е затворена за нови отговори.